Laravel update 4.1 to 4.2 error


Error message : mcrypt_decrypt(): The IV parameter must be as long as the blocksize

$ php artisan key:generate

One thought on “Laravel update 4.1 to 4.2 error

  1. Sebetulnya masalah ini pernah saya temuin beberapa kali, sewaktu saya upgrade dari 4.1 ke 4.2 ataupun downgrade versi laravel dari 4.2 ke 4.1 melalui composer di Ubuntu. Ternyata permasalahannya itu dari package “repository” laravelnya. Solusi yang biasa saya kerjakan :
    1) Download “composer” (https://getcomposer.org/)
    2) Rename “composer.phar” menjadi “composer” dan copy-paste di folder path laravelnya (eg: /var/www/html/laravel)
    3) Reload/rebuild repository package laravel-nya (composer.json), menggunakan composer :
    $ cd /var/www/html/laravel
    $ composer update
    4) Tunggu sampai proses reload/rebuild repository-nya.
    5) Perbaiki chmod & chown dari file & folder laravelnya. Link permission ada di Github saya (https://github.com/dfdenni/l4permission)

    Salam kenal mas…

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s