Fedora 22 64 bit error while installing libstdc++.i686


Actually I need thsi lib to run android SDK then the error appear, here is the error :

[root@localhost yusuf]# dnf install libstdc++.i686
Last metadata expiration check performed 0:10:47 ago on Fri Sep 11 09:20:54 2015.
Dependencies resolved.
================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
glibc i686 2.21-7.fc22 updates 4.2 M
libgcc i686 5.1.1-4.fc22 updates 91 k
libstdc++ i686 5.1.1-4.fc22 updates 444 k
nss-softokn-freebl i686 3.20.0-1.0.fc22 updates 196 k

Transaction Summary
================================================================================
Install 4 Packages

Total size: 4.9 M
Installed size: 17 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] libstdc++-5.1.1-4.fc22.i686.rpm: Already downloaded
[SKIPPED] glibc-2.21-7.fc22.i686.rpm: Already downloaded
[SKIPPED] libgcc-5.1.1-4.fc22.i686.rpm: Already downloaded
[SKIPPED] nss-softokn-freebl-3.20.0-1.0.fc22.i686.rpm: Already downloaded
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache till the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’
Error: Transaction check error:
file /usr/share/gcc-5.1.1/python/libstdcxx/v6/printers.py from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
file /usr/share/gcc-5.1.1/python/libstdcxx/v6/printers.pyc from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
file /usr/share/gcc-5.1.1/python/libstdcxx/v6/printers.pyo from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
file /usr/share/gcc-5.1.1/python/libstdcxx/v6/xmethods.py from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
file /usr/share/gcc-5.1.1/python/libstdcxx/v6/xmethods.pyc from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
file /usr/share/gcc-5.1.1/python/libstdcxx/v6/xmethods.pyo from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64

Error Summary
————-

look, libstdc++-5.1.1-4.fc22.i686 is conflict with libstdc++-5.1.1-1.fc22.x86_64, now remove libstdc++-5.1.1-1.fc22.x86_64 using :

dnf remove libstdc++-5.1.1-1.fc22.x86_64

then continue your installation

# dnf install libstdc++.i686

do not worry, if it cause an error you can reinstalling it later.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s